Problems installing MIDlet that uses Bouncy Castle

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problems installing MIDlet that uses Bouncy Castle

Martin Herfurt
Hi all,
last week I started playing with the BouncyCastle Crypto API. As I tried
some programming based on some examples I found, I couldn't install the
files on the phones I have for testing.

To make this reproducable:
*I use the bouncycastle lightweight-api (version 1.28 ( also tried
version 1.29)).
*As MIDlet code, I use the EncryptText-Example from the developerWorks
tutorial.
*for the building, preverification and obfuscating i use Sun WTK2.2
together with the ProGuard obfuscator tool.

After building, preverifying and obfuscating i transfer the MIDlet over
to the phone via Bluetooth (as usual).
Installing the MIDlet results in the message "The Java server has denied
the installation of this software." on the SE P910i and in the message
"Authorization failed" when i install it on my Nokia 6600.

These are both phones with MIDP 2.0 and CLDC 1.0.

This is very weird, since the compiled application does run in the
emulator as supposed to.

Can anybody help me with this?

Thank you in advance,
Martin

--
Martin Herfurt

mailto: [hidden email]
http://trifinite.org/
cell: +43 676 3787909

The bigger the theory the better.