PROBLEM WITH PREMATURE END OF STREAM IN PARTIALINPUTSTREAM

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

PROBLEM WITH PREMATURE END OF STREAM IN PARTIALINPUTSTREAM

Francisco Mendez
Can anyone help me?

"java.io.EOFException: premature end of stream in PartialInputStream"

I keep getting this exception when attempting to decrypt?

I have seen posts related to this, and they mentioned that with jdk16 version of the library fixes the issue.  I gave it a try and true, it works.
But, I like to use the latest version which I understand is jdk15on (version 1.57); but it is not working, it keeps giving me that exception when decrypting.

is there a fix for this?

(also, I don't like to use jdk16, because I understand is no longer supported and it has reached end of life, correct?  hence, I like to use jdk15on.)

thanks in advance for your help.
Francisco.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: PROBLEM WITH PREMATURE END OF STREAM IN PARTIALINPUTSTREAM

David Hook-3

I'm assuming this is with the PGP package, yes the jdk16 releases are
definitely past end of life. So the first thing would be that it is
probably the case that "not seeing the exception" and "issue being
fixed" are not the same thing.

I'd need to know more about what's going on - this normally happens
around compressed data. The first thing to check would be that the
message is being created correctly, that is the compressed data stream
is being closed off correctly *before* the encrypted data stream is.

Regards,

David

On 22/07/17 00:07, Francisco Mendez wrote:

> Can anyone help me?
>
> "java.io.EOFException: premature end of stream in PartialInputStream"
>
> I keep getting this exception when attempting to decrypt?
>
> I have seen posts related to this, and they mentioned that with jdk16 version of the library fixes the issue.  I gave it a try and true, it works.
> But, I like to use the latest version which I understand is jdk15on (version 1.57); but it is not working, it keeps giving me that exception when decrypting.
>
> is there a fix for this?
>
> (also, I don't like to use jdk16, because I understand is no longer supported and it has reached end of life, correct?  hence, I like to use jdk15on.)
>
> thanks in advance for your help.
> Francisco.
>
>


Loading...