Quantcast

PKCS10CertificationRequest deprecated

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

PKCS10CertificationRequest deprecated

Paulo Ricardo Ribeiro
Hello,

I'm using PKCS10CertificationRequest to load a certificate request from a byte array. The problem is that I get a warning saying that the PKCS10CertificationRequest is deprecated, but I don't see what else should I use to load the Certificate Request.
Has anyone worked with a different class to do that?

By the way, I'm using maven, and this is the dependency I'm using:

<groupId>org.bouncycastle</groupId>
<artifactId>bcprov-jdk15on</artifactId>
<version>147</version>

Thanks
Paulo Ricardo
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: PKCS10CertificationRequest deprecated

David Hook-2

See the org.bouncycastle.pkcs package in the bcpkix package.

Regards,

David

On 03/05/12 22:46, Paulo Ricardo Ribeiro wrote:

> Hello,
>
> I'm using PKCS10CertificationRequest to load a certificate request from a
> byte array. The problem is that I get a warning saying that the
> PKCS10CertificationRequest is deprecated, but I don't see what else should I
> use to load the Certificate Request.
> Has anyone worked with a different class to do that?
>
> By the way, I'm using maven, and this is the dependency I'm using:
>
> <groupId>org.bouncycastle</groupId>
> <artifactId>bcprov-jdk15on</artifactId>
> <version>147</version>
>
> Thanks
> Paulo Ricardo
>
> --
> View this message in context: http://bouncy-castle.1462172.n4.nabble.com/PKCS10CertificationRequest-deprecated-tp4605924.html
> Sent from the Bouncy Castle - Dev mailing list archive at Nabble.com.
>
>


Loading...