Blocker issue when upgrading BouncyCastle

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Blocker issue when upgrading BouncyCastle

tech user
Hi,

Hitting a blocker when moving from 1.46 to 1.56 with symmetric key
encryption/ decryption
We are using BouncyCastle 1.46 for Symmetric Key encryption and
decryption, store the encrypted keys in our database , decrypt them on
demand and to use it .

When we test for decryption using 1.56 jar  that are encrypted using
1.46 its failing only when the encrypted byte size is less than or
equal to key size.

We are using "AES/CTS/NoPadding" , "BC".

Is there a way to get around this issue. Any Pointers etc...

thanks in advance

Reply | Threaded
Open this post in threaded view
|

Re: Blocker issue when upgrading BouncyCastle

David Hook-3

Not sure. I'd really have to have a look at what was being done.

Regards,

David

On 08/06/17 05:36, Sivaji Adurthy wrote:

> Hi,
>
> Hitting a blocker when moving from 1.46 to 1.56 with symmetric key
> encryption/ decryption
> We are using BouncyCastle 1.46 for Symmetric Key encryption and
> decryption, store the encrypted keys in our database , decrypt them on
> demand and to use it .
>
> When we test for decryption using 1.56 jar  that are encrypted using
> 1.46 its failing only when the encrypted byte size is less than or
> equal to key size.
>
> We are using "AES/CTS/NoPadding" , "BC".
>
> Is there a way to get around this issue. Any Pointers etc...
>
> thanks in advance
>
>